読者です 読者をやめる 読者になる 読者になる

文系seの備忘録

Excelの改行でひたすらスペースを打っていた機械音痴の文系seが日々の備忘録を綴る。

WebdriverからFirefox起動時に"Unable to connect to host"エラー


最新のFirefoxに更新したら「Unable to connect to host」エラーが出た。



■ 原因

WebDriverのバージョンがFirefoxのバージョンに対応していないのが原因。



■ 対応

1.Firefoxの自動バージョンアップは設定で無効にしておく


2.FireFoxESR版を使用する

ESR版というのは「Extended Support Release」という法人向けの延長サポート版で、
最新機能が反映されるのは通常版に投入されてから数開発サイクル後になるが
安全性やセキュリティ面は考慮されているもの。

以下からダウンロードする

Web ブラウザ Mozilla Firefox — 各国語版の Firefox Extended Support Release をダウンロード — Mozilla


法人向けって書いてあるけど個人でダウンロードしても問題ありません。


最新である必要がなければESR版をおすすめします。